Investigating a potential issue

Incident Report for Genetec Cloud Products

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 08, 2026 - 17:15 EDT

Investigating

We’re investigating reports of a potential issue of email deliverability affecting Global SC SaaS → Web, desktop, and Mobile applications . We are working on it. We apologize for any inconvenience this may cause.
Posted Jul 08, 2026 - 11:30 EDT