Connectivity issue with Security Center SaaS

Incident Report for Genetec Cloud Products

Resolved

We are pleased to inform you that the issue has been resolved.

Thank you for your patience during this time. Please do not hesitate to contact us if you have any concerns or questions.
Posted Mar 03, 2025 - 13:45 EST

Monitoring

Connectivity has been restored. We are now monitoring the situation to ensure that everything is working.
Posted Mar 03, 2025 - 13:40 EST

Update

We are continuing to work on a fix for this issue.
Posted Mar 03, 2025 - 13:09 EST

Update

We are continuing to work on a fix for this issue.
Posted Mar 03, 2025 - 13:03 EST

Update

We have identified a potential cause of the incident and are implementing a solution.

We apologize for any inconvenience and will keep you informed as we have more information. Thank you for your understanding as we work to fix the problem.
Posted Mar 03, 2025 - 12:25 EST

Identified

A connectivity issue has been identified affecting the Canada Central region. We are actively investigating the issue and will provide and update within the hour.
Posted Mar 03, 2025 - 12:10 EST
This incident affected: Security Center SaaS (Web, desktop, and Mobile applications).