Query performance impacted for systems hosted in East US region

Incident Report for Genetec Cloud Products

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 14:01 EST

Investigating

We are currently investigating an issue which causes slow performance on queries from Operations Desktop client and Web App. Updates will be posted as the situation evolves.
Posted Nov 03, 2025 - 13:21 EST
This incident affected: Security Center SaaS (Web, desktop, and Mobile applications).