Genetec Clearance - Thumbnail not displayed in portal

Incident Report for Genetec Cloud Products

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 14:21 EDT

Update

We identified other pages inside the portal using images in different scenarios that need the same fix to be implemented. We will be deploying them to all environments.
Posted Mar 16, 2026 - 12:36 EDT

Monitoring

A fix has been implemented and have validated it on our internal environments. We are deploying the fix in all environments.
Posted Mar 16, 2026 - 12:00 EDT

Identified

An issue has been identified to affect the thumbnail associated to evidences of Clearance in all regions. We identified the issue is related with the latest version update for Chrome and Edge (March 14th). We are working on a fix and will publish an update within the next hour.
Posted Mar 16, 2026 - 11:44 EDT
This incident affected: Clearance (US, US Government, Europe, United Kingdom, Canada, Australia).