Genetec Clearance performance degradation

Incident Report for Genetec Cloud Products

Resolved

The issue has been resolved. Video thumbnails are now being processed within normal timeframes.
Posted Jul 29, 2025 - 18:37 EDT

Update

We are continuing to monitor for any further issues.
Posted Jul 29, 2025 - 09:19 EDT

Update

Video and image thumbnails are currently being processed. All remaining files in the queue will be completed, and processing time will return to normal within the next few hours.
Posted Jul 28, 2025 - 16:06 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2025 - 13:41 EDT

Identified

A performance degradation issue has been identified to affect thumbnail generation, video conversions and redactions. We are actively monitoring the issue and will provide update within an hour.
Posted Jul 28, 2025 - 13:18 EDT
This incident affected: Clearance (US).