Issue affecting West Europe camera metadata in SC SaaS investigation

Incident Report for Genetec Cloud Products

Resolved

We are pleased to inform you that the issue has been resolved.

Thank you for your patience during this time. Please do not hesitate to contact us if you have any concerns or questions.
Posted Jun 15, 2026 - 20:23 EDT

Monitoring

Customers in West Europe may have experienced delays in receiving incoming camera metadata in SC SaaS investigation.

The issue was resolved and we are closely monitoring the situation.
Posted Jun 15, 2026 - 20:03 EDT

Investigating

We’re investigating reports of a potential issue affecting West Europe . We are working on it. We apologize for any inconvenience this may cause.
Posted Jun 15, 2026 - 18:51 EDT
This incident affected: Security Center SaaS (Investigation).