Investigating an incident impacting Cloud Storage product

Incident Report for Genetec Cloud Products

Resolved

We are pleased to inform you that the issue has been resolved.

Thank you for your patience during this time. Please do not hesitate to contact us if you have any concerns or questions.
Posted May 11, 2026 - 11:33 EDT

Investigating

We are currently investigating an incident that is impacting Cloud Storage.
Cloud storage is currently unavailable. Uploading or downloading video from the Cloud is impacted and the Security Center cloud playback role shows in warning.
We are working to resolve the issue as quickly as possible. We apologize for any inconvenience this may cause.
We will provide updates as they become available and appreciate your patience while we work to resolve the issue.
Posted May 11, 2026 - 10:28 EDT
This incident affected: Cloud Storage.