Genetec Security Center SaaS - Inconsistent camera state reported

Incident Report for Genetec Cloud Products

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 15:42 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 30, 2026 - 15:15 EDT

Investigating

An issue affecting direct-to-cloud camera state has been identified. Cameras might incorrectly appear as online or offline in the Web, Desktop and Mobile applications.

We are actively investigating the issue and will provide an update within an hour.
Posted Mar 30, 2026 - 13:57 EDT
This incident affected: Security Center SaaS (Web, desktop, and Mobile applications, Video).