System Management portal – Potential issues accessing subscriptions.genetec.com

Incident Report for Genetec Cloud Products

Resolved

This incident has been resolved. You should now have access to the subscriptions portal.
We apologize again for any inconvenience that you faced during this period.
Posted Apr 23, 2026 - 18:05 EDT

Monitoring

We have recovered access to the System Management portal for most affected users. Integrators may have to join existing access requests to systems they have lost access to.
Posted Apr 23, 2026 - 15:36 EDT

Update

We have started recovering access to a subset of users. We are working on recovering it for everyone affected.
Posted Apr 23, 2026 - 14:37 EDT

Update

We are continuing to work on a fix for this issue, we understand this disrupts your workflow and we appreciate your patience.
Posted Apr 23, 2026 - 11:49 EDT

Update

Our team is still actively working on recovering access to affected users. Note that integrators who lost access to the System Management Portal may also have their system access requests revoked.
Posted Apr 23, 2026 - 11:44 EDT

Identified

An issue affecting the System Management portal may cause certain users to not be able to access subscriptions.genetec.com. We apologize for any inconvenience this may cause and we are working to resolve the problem.
Posted Apr 23, 2026 - 10:35 EDT

Investigating

We’re investigating reports of a potential issue affecting access to the System Management portal (subscriptions.genetec.com). We are working on it. We apologize for any inconvenience this may cause.
Posted Apr 23, 2026 - 10:29 EDT
This incident affected: System Management portal (subscriptions.genetec.com).