Security Center SaaS Web UI intermittent issues.

Incident Report for Genetec Cloud Products

Resolved

We are pleased to inform you that the issue has been resolved.

Thank you for your patience during this time. Please do not hesitate to contact us if you have any concerns or questions.
Posted Jul 02, 2025 - 15:56 EDT

Monitoring

We have detected an intermittent incident that is impacting the Security Center SaaS Web UI. Some users may experience a black screen after log in.

We are closely monitoring the situation to ensure the issue is fully resolved.
Posted Jul 02, 2025 - 15:26 EDT
This incident affected: Security Center SaaS (Web, desktop, and Mobile applications).