Inconsistent camera state reported in Security Center SaaS - EastUS region

Incident Report for Genetec Cloud Products

Resolved

We are pleased to inform you that the issue has been resolved.

Thank you for your patience during this time. Please do not hesitate to contact us if you have any concerns or questions.
Posted Apr 01, 2026 - 12:36 EDT

Update

We are continuing to monitor for any further issues.
Posted Apr 01, 2026 - 11:07 EDT

Monitoring

The current issue has been resolved. We are closely monitoring the situation.
Posted Apr 01, 2026 - 11:07 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 01, 2026 - 10:42 EDT

Investigating

We are currently investigating an incident that is only impacting the device state in Security Center SaaS (live and recording functionalities are not impacted). We are working to resolve the issue as quickly as possible. We apologize for any inconvenience this may cause.
At this time, we do not have any further details on the cause of the incident or an estimated time for resolution. We will provide updates as they become available and appreciate your patience while we work to resolve the issue.
Posted Apr 01, 2026 - 08:00 EDT
This incident affected: Security Center SaaS (Web, desktop, and Mobile applications, Video).