Genetec Security Center SaaS - Email Delivery Issue

Incident Report for Genetec Cloud Products

Resolved

This incident has been resolved.
Posted Apr 14, 2026 - 18:22 EDT

Update

We are still actively investigating this issue with our email provider and will continue to provide updates as we learn more.
Posted Apr 14, 2026 - 17:16 EDT

Investigating

We’ve identified an issue impacting the ability to send notification emails from Security Center SaaS systems. If you’ve experienced any disruptions, please know that we are actively investigating the problem in collaboration with our email provider.
We apologize for any inconvenience this may cause
Posted Apr 14, 2026 - 14:03 EDT
This incident affected: Security Center SaaS (Web, desktop, and Mobile applications).