Genetec Cloud Storage Playback Functionality Degradation
Incident Report for Genetec Cloud Products
Resolved
This incident has been resolved.
Posted Jan 03, 2024 - 10:00 EST
Investigating
An issue affecting video playback of Cloud Storage has been identified. No video loss has occurred.
Posted Dec 21, 2023 - 13:00 EST
This incident affected: Cloud Storage.