Genetec Security Center SaaS - Enrollment issues of Axis direct-to-cloud devices on newly created systems - Functionality Degradation

Incident Report for Genetec Cloud Products

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 16:37 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2026 - 14:48 EDT

Investigating

An issue affecting enrollment of Axis direct-to-cloud devices (cameras, ApbG, intercoms) has been identified on newly created systems.

We are actively investigating the issue and will provide updates.
Posted Apr 21, 2026 - 13:27 EDT
This incident affected: Security Center SaaS (Device management (enrollment and device configuration)).