Investigating a potential issue

Incident Report for Genetec Cloud Products

Resolved

This incident has been resolved.
Posted Jun 19, 2026 - 10:20 EDT

Investigating

We’re investigating reports of a potential issue affecting Clearance . We are working on it. We apologize for any inconvenience this may cause.
Posted Jun 19, 2026 - 09:39 EDT