We are pleased to inform you that the issue has been resolved. Thank you for your patience during this time.
Posted Apr 15, 2026 - 12:46 EDT
Identified
Issue Identified – Delayed Forensic Events (West Europe) A small subset of customers may experience delays in forensic events appearing within the Investigation feature of Security Center SaaS in the West Europe region. We have identified the root cause and are actively working to mitigate the issue. Existing forensic events are not impacted, and no data loss has occurred. We will continue to provide updates as progress is made. Thank you for your understanding.
Posted Apr 15, 2026 - 10:03 EDT
Investigating
We’re investigating reports of a potential issue affecting SC SaaS Intelligent Search Availability in West Europe region. We are working on it. We apologize for any inconvenience this may cause.
Posted Apr 15, 2026 - 09:02 EDT
This incident affected: Security Center SaaS (Web, desktop, and Mobile applications).