A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2026 - 23:08 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 14, 2026 - 19:03 EDT
Update
It was identified that the issue only affected Prod US & Prod EU. Rectifications are still in progress.
Posted Apr 14, 2026 - 15:49 EDT
Identified
The issue has been identified and a fix is being implemented. The propagation of resulting issues was stopped.
Posted Apr 14, 2026 - 12:24 EDT
Investigating
We’re investigating reports of a potential issue affecting ClearID Functionality. We are working on it. We apologize for any inconvenience this may cause.
Posted Apr 14, 2026 - 11:15 EDT
This incident affected: ClearID (Demo (https://demo.clearid.io), Global US (https://portal.clearid.io), Europe (https://portal.eu.clearid.io/), Canada (https://portal.ca.clearid.io/), Australia (https://portal.au.clearid.io/)).