Axis Direct-to-cloud device Enrollment Problems

Incident Report for Genetec Cloud Products

Resolved

This incident has been resolved.
Posted Jun 23, 2026 - 12:51 EDT

Monitoring

Services are back to normal. We are monitoring the situation
Posted Jun 23, 2026 - 11:58 EDT

Investigating

We’re investigating an issue affecting all Axis direct-to-cloud devices (camera, intercom, Axis-Powered-by-Genetec) enrollment.
Posted Jun 23, 2026 - 11:42 EDT
This incident affected: Security Center SaaS (Device management (enrollment and device configuration)).