Networking problem impacting multiple products

Incident Report for Genetec Cloud Products

Resolved

This incident has been resolved.

Incident Update – Cloudflare Outage Impact

On Tuesday morning (EST), we experienced service disruptions due to the global Cloudflare outage. We use Cloudflare to secure our platform. During the outage period, the service was unstable—sometimes recovering and then going partially down again. Depending on when authentication tokens needed to be renewed, this issue may have impacted the recording of certain cameras in Security Center SaaS.

We apologize for any inconvenience caused and appreciate your understanding.

For more details, please refer to Cloudflare’s official Root Cause Analysis: https://blog.cloudflare.com/18-november-2025-outage/.
Posted Nov 18, 2025 - 11:50 EST

Update

We are still closely monitoring the situation to ensure the issue is fully resolved for all products.
Posted Nov 18, 2025 - 10:29 EST

Update

We are still closely monitoring the situation to ensure the issue is fully resolved. Services should be accessible.
Posted Nov 18, 2025 - 10:04 EST

Monitoring

We are closely monitoring the situation to ensure the issue is fully resolved.
Posted Nov 18, 2025 - 10:00 EST

Update

Services are recovering, but functionality remains inconsistent. Customers may experience intermittent issues or higher-than-normal error rates while we continue remediation efforts. Our team is actively working to stabilize all systems.
Posted Nov 18, 2025 - 09:28 EST

Update

We are deploying mitigations to limit the impact of the outage on our services.
Posted Nov 18, 2025 - 08:48 EST

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 08:24 EST

Identified

Functionality remains inconsistent or unavailable. Customers may experience intermittent issues or higher-than-normal error rates while we continue remediation efforts.
Posted Nov 18, 2025 - 07:49 EST

Monitoring

Our systems are currently recovering, and we are actively monitoring to ensure everything returns to normal. Thank you for your patience.
Posted Nov 18, 2025 - 07:23 EST

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 07:18 EST

Identified

Cloudflare acknowledged the problem. See https://www.cloudflarestatus.com/ for more details.
We will resolve this incident once we have received confirmation that the issue has been resolved from our upstream provider.
Posted Nov 18, 2025 - 06:52 EST

Investigating

Our provider Cloudflare is currently experiencing an issue which is affecting the products / components below.
We will resolve this incident once we have received confirmation that the issue has been resolved from our upstream provider.
Posted Nov 18, 2025 - 06:32 EST
This incident affected: ClearID (Demo (https://demo.clearid.io), Global US (https://portal.clearid.io), Europe (https://portal.eu.clearid.io/), Canada (https://portal.ca.clearid.io/), Australia (https://portal.au.clearid.io/)), Clearance (US, US Government, Europe, Canada, Australia), Operations Center (Canada Central (https://ca-central.ops.center), US (https://ops.center), Europe West (eu-west.ops.center), Australia East (aus-east.ops.center)), Cloudrunner (US Government (https://portal.autovu.cloud), Australia (https://au.cloudrunner.tech), Canada (https://ca.cloudrunner.tech)), Security Center SaaS (Web, desktop, and Mobile applications, Device management (enrollment and device configuration), Video, Video Recordings, Access Control, System Management portal), and Curb Sense.