Genetec Cloud Storage functionality degradation
Incident Report for Genetec Cloud Products
Resolved
This incident has been resolved.
Posted Feb 13, 2022 - 18:39 EST
Investigating
We are currently investigating this issue.
Posted Feb 13, 2022 - 17:17 EST
This incident affected: Cloud Storage.