Newly enrolled cameras on Genetec Cloudlink Devices appear twice

Incident Report for Genetec Cloud Products

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 15:31 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 11, 2025 - 14:58 EST

Investigating

We are currently investigating an issue where newly enrolled cameras are appearing twice on Genetec Cloudlink devices. This duplication does not affect live viewing or playback functionality.
Please note:
- Enrolling new cameras to Genetec Cloudlink devices will result in creating a duplicate entrie
- Deleting one of the duplicate entries will not remove the other.

Our team is actively working on a fix and will provide updates as soon as they become available. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Nov 11, 2025 - 12:12 EST
This incident affected: Security Center SaaS (Device management (enrollment and device configuration)).