Service Disruption - Tasks are not showing up in Enforcement Center (Curb Sense)

Incident Report for Genetec Cloud Products

Resolved

The issue has been resolved and everything is working again.
Posted Mar 09, 2026 - 10:35 EDT

Monitoring

We are currently monitoring the implemented fix, everything is working again. No data (tasks) are lost.
Posted Mar 09, 2026 - 10:34 EDT

Identified

The issue has been identified and a fix has been implemented.
Posted Mar 09, 2026 - 10:33 EDT

Investigating

We are currently experiencing a service disruption. Our team is working to identify the root cause and implement a solution. Tasks are not showing up in Enforcement Center (Curb Sense)

We will send an additional update as soon as possible.
Posted Mar 09, 2026 - 10:24 EDT
This incident affected: Curb Sense.