Genetec SSO functionality degradation
Incident Report for Genetec Cloud Products
Resolved
This incident has been resolved.
Posted May 27, 2024 - 14:50 EDT
Update
The issue has been resolved. We are continuing to monitor for any further issues.
Posted May 27, 2024 - 13:50 EDT
Monitoring
An issue affecting the MFA by email of Genetec-managed accounts has been identified. If you've noticed any issues, rest assured, we are actively monitoring the issue and will provide an update within an hour.
Posted May 27, 2024 - 12:02 EDT
This incident affected: Login (Production).