SC SaaS Access Control – Potential service issue

Incident Report for Genetec Cloud Products

Resolved

We are pleased to inform you that the issue has been resolved. Thank you for your patience during this time.
Posted Feb 18, 2026 - 14:28 EST

Monitoring

We identified and fixed the issue and are currently monitoring the system. Enrollment/unit deletion should now be working as expected and sync'ing to Security Center.
Posted Feb 18, 2026 - 13:17 EST

Investigating

We’re investigating reports of a potential issue affecting SC SaaS Access Control Functionality. We are working on it. We apologize for any inconvenience this may cause.
Posted Feb 18, 2026 - 11:51 EST
This incident affected: Security Center SaaS (Access Control).