Issue with our DNS provider

Incident Report for Genetec Cloud Products

Resolved

The issue is resolved. Everything is operational.
Posted Mar 19, 2026 - 05:56 EDT

Monitoring

Our DNS provider pushed some changes, the issue seems to be resolved, we are monitoring the situation.
Posted Mar 19, 2026 - 04:18 EDT

Identified

The issue has been identified and services are partially back online.
Posted Mar 19, 2026 - 04:03 EDT

Investigating

Our DNS provider is currently experiencing an issue which is causing service disruptions.

The following services are affected:
* Q2C BackOffice
* Patroller
* Curb Sense Mobile

We will provide an update as soon as we receive additional information from our provider.
Posted Mar 19, 2026 - 03:56 EDT
This incident affected: Curb Sense.