SC SaaS Communications – Potential service issue in East US 2

Incident Report for Genetec Cloud Products

Resolved

We are pleased to inform you that the issue has been resolved. Thank you for your patience during this time.
Posted Apr 08, 2026 - 21:30 EDT

Investigating

We’re investigating reports of a potential issue affecting SC SaaS Communications Functionality in East US 2. We are working on it. We apologize for any inconvenience this may cause.
Posted Apr 08, 2026 - 20:53 EDT
This incident affected: Security Center SaaS (Communications).