Genetec ClearID Login issues
Incident Report for Genetec Cloud Products
Resolved
Microsoft seems to have resolved the problem with Azure AD, operations should not longer be affected.
Posted Mar 16, 2021 - 06:10 EDT
Monitoring
Microsoft Engineering teams have rolled out a fix to all affected regions. Internal telemetry and customer reports suggests that the error rate for dependent services is rapidly decreasing. Microsoft services are starting to see signs of recovery. Some services and offerings may have varying times of recovery following the underlying fix.

More details: https://status.azure.com
Posted Mar 15, 2021 - 20:53 EDT
Update
We are continuing to work on a fix for this issue.
Posted Mar 15, 2021 - 18:13 EDT
Update
Microsoft Engineering teams have rolled out a fix to all affected regions. Internal telemetry and customer reports suggests that the error rate for dependent services is rapidly decreasing. Microsoft services are starting to see signs of recovery. Some services and offerings may have varying times of recovery following the underlying fix. The next update will be provided in 60 minutes or as events warrant.
Posted Mar 15, 2021 - 18:11 EDT
Update
Microsoft has mitigated some Azure AD tenants, certains ClearID Customers with SSO can now authenticate successfully to ClearID.

An issue reported by Microsoft causes logins to fail with Azure Active Directory. Microsoft is investigating the issue at the moment.
https://twitter.com/azuresupport
https://status.azure.com
Posted Mar 15, 2021 - 16:21 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 15, 2021 - 16:21 EDT
Investigating
An issue reported by Microsoft causes logins to fail in ClearID because there's a problem with Microsoft Azure Active Directory.
Posted Mar 15, 2021 - 16:20 EDT
This incident affected: ClearID (Demo (https://demo.clearid.io), Global (https://portal.clearid.io)).