Genetec Clearance functionality degradation incident

Incident Report for Genetec Cloud Products

Resolved

We could confirm this increase was sporadic and normal services are now back to normal.
Posted May 26, 2026 - 13:27 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 26, 2026 - 12:49 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 26, 2026 - 11:58 EDT

Identified

An issue has been identified to affect the Device Registry of Clearance in specific Europe. We are actively monitoring the issue and will provide update within an hour.
Posted May 26, 2026 - 11:40 EDT
This incident affected: Clearance (Europe).