Genetec SC SaaS services unavailable in Europe, Canada and Autralia regions

Incident Report for Genetec Cloud Products

Resolved

This incident has been resolved.
Posted Aug 13, 2025 - 11:54 EDT

Update

We are continuing to monitor for any further issues.
Posted Aug 13, 2025 - 11:34 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 13, 2025 - 11:33 EDT

Investigating

An issue has been identified to affect all SC SaaS services in Europe, Canada and Australia regions. Access to SC SaaS Web portals is not working.

We are actively working on the issue and will provide update within an hour.
Posted Aug 13, 2025 - 11:32 EDT
This incident affected: Security Center SaaS (Web, desktop, and Mobile applications, Device management (enrollment and device configuration), Video, Video Recordings, Access Control, System Management portal).