Genetec Security Center SaaS - Temporary interruption of Web Operations and Mobile functionalities

Incident Report for Genetec Cloud Products

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 13:00 EDT

Monitoring

A subset of Security Center SaaS systems experienced an unexpected service restart between between 11:15 AM and 12:00 PM EST. This has caused a temporary interruption of connectivity to the Operations web and mobile applications during this period.

The problem has been identified and corrected. We are currently monitoring the situation.
Posted Apr 01, 2026 - 11:12 EDT
This incident affected: Security Center SaaS (Web, desktop, and Mobile applications).