Service Outage Investigation in Progress

Incident Report for Genetec Cloud Products

Resolved

The issue has been mitigated and the service is currently stable. Our teams are closely monitoring the system to ensure continued normal operation.
Posted Nov 18, 2025 - 04:54 EST

Investigating

We are currently experiencing a service disruption that may impact the SC SaaS application. Our teams are actively investigating and working to restore full functionality as soon as possible. Further updates will be provided as more information becomes available.
Posted Nov 18, 2025 - 04:30 EST
This incident affected: Security Center SaaS (Web, desktop, and Mobile applications, Video).