Resolved
Search capabilities in the Canada region has resorbed and is now working as intended. We are keeping a close eye on the capability to ensure proper function is maintained. Sorry for any inconvenience this may have caused.
Investigating
We are currently investigating a latency degradation on search capabilities in the Canada region. Evidences and cases are taking longer than expected to be rendered available. All data is properly handled and only the search delay is affecting the environment. We are actively investigating the issue and will update the incident within the next hour.